What’s Vulnerable › Vulnerabilities
CVE-2022-30122: Denial of Service Vulnerability in Rack Multipart Parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-400
Description
A possible denial of service vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 in the multipart parsing component of Rack.
Affected products
- Debian Linux: 11.0
- Rack Project Rack: from 1.2 before 2.0.9.1; from 2.1.0 before 2.1.4.1; from 2.2.0 before 2.2.3.1 — fixed in 2.0.9.1, 2.1.4.1, 2.2.3.1
- Rubygems Rack: from 1.2 before 2.0.9.1; from 2.1 before 2.1.4.1; from 2.2 before 2.2.3.1; 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5 (+68) — fixed in 2.0.9.1, 2.1.4.1, 2.2.3.1
How to fix
Upgrade to a fixed version: Rack Project Rack 2.0.9.1, 2.1.4.1, 2.2.3.1; Rubygems Rack 2.0.9.1, 2.1.4.1, 2.2.3.1. Check the vendor advisory for mitigations.
References
- https://discuss.rubyonrails.org/t/cve-2022-30122-denial-of-service-vulnerability-in-rack-multipart-parsing/80729
- https://security.gentoo.org/glsa/202310-18
- https://security.netapp.com/advisory/ntap-20231208-0012/
- https://www.debian.org/security/2023/dsa-5530
- https://discuss.rubyonrails.org/t/cve-2022-30122-denial-of-service-vulnerability-in-rack-multipart-parsing/80729
- https://security.gentoo.org/glsa/202310-18
- https://security.netapp.com/advisory/ntap-20231208-0012/
- https://www.debian.org/security/2023/dsa-5530
Get alerted when CVE-2022-30122 or the next vulnerability affects your stack