What’s Vulnerable › Vulnerabilities
CVE-2022-30123: Possible shell escape sequence injection vulnerability in Rack
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-150
Description
A sequence injection vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 which could allow is a possible shell escape in the Lint and CommonLogger components of Rack.
Affected products
- Debian Linux: 11.0
- Rack Project Rack: before 2.0.9.1; from 2.1.0 before 2.1.4.1; from 2.2.0 before 2.2.3.1 — fixed in 2.0.9.1, 2.1.4.1, 2.2.3.1
- Rubygems Rack: before 2.0.9.1; from 2.1 before 2.1.4.1; from 2.2 before 2.2.3.1; 0.1.0, 0.2.0, 0.3.0, 0.4.0, 0.9.0, 0.9.1 (+84) — fixed in 2.0.9.1, 2.1.4.1, 2.2.3.1
How to fix
Upgrade to a fixed version: Rack Project Rack 2.0.9.1, 2.1.4.1, 2.2.3.1; Rubygems Rack 2.0.9.1, 2.1.4.1, 2.2.3.1. Check the vendor advisory for mitigations.
References
- https://discuss.rubyonrails.org/t/cve-2022-30123-possible-shell-escape-sequence-injection-vulnerability-in-rack/80728
- https://security.gentoo.org/glsa/202310-18
- https://security.netapp.com/advisory/ntap-20231208-0011/
- https://www.debian.org/security/2023/dsa-5530
- https://discuss.rubyonrails.org/t/cve-2022-30123-possible-shell-escape-sequence-injection-vulnerability-in-rack/80728
- https://security.gentoo.org/glsa/202310-18
- https://security.netapp.com/advisory/ntap-20231208-0011/
- https://www.debian.org/security/2023/dsa-5530
Get alerted when CVE-2022-30123 or the next vulnerability affects your stack