What’s Vulnerable › Vulnerabilities
CVE-2022-30130: .NET Framework Denial of Service Vulnerability
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-10 · updated 2026-06-17
Description
.NET Framework Denial of Service Vulnerability
Affected products
- Microsoft .NET Framework: 3.5, 4.6.2, 4.7, 4.7.1, 4.7.2, 4.8 (+5)
- Microsoft .NET Framework 3.5 AND 4.6/4.6.2: from 10.0.0 before 10.0.10240.19624 — fixed in 10.0.10240.19624
- Microsoft .NET Framework 4.6.2: from 4.7.0 before 4.7.03946.07 — fixed in 4.7.03946.07
- Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2: from 4.7.0 before 4.7.03946.07 — fixed in 4.7.03946.07
How to fix
Upgrade to a fixed version: Microsoft .NET Framework 3.5 AND 4.6/4.6.2 10.0.10240.19624; Microsoft .NET Framework 4.6.2 4.7.03946.07; Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2 4.7.03946.07. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-30130
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-30130
Get alerted when CVE-2022-30130 or the next vulnerability affects your stack