What’s Vulnerable › Vulnerabilities
CVE-2022-30141: Windows Lightweight Directory Access Protocol (LDAP) Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-15 · updated 2026-06-17
Description
Windows Lightweight Directory Access Protocol (LDAP) Remote Code Execution Vulnerability
Affected products
- Microsoft Windows 10 Version 1607: 20h2, 21h1, 21h2, 1607, 1809
- Microsoft Windows 11 version 21H2: all versions
- Microsoft Windows 7: all versions
- Microsoft Windows 8.1: all versions
- Microsoft Windows RT 8.1: all versions
- Microsoft Windows Server 2008: r2-sp1
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: 20h2
- Microsoft Windows Server 2019: all versions
- Microsoft Windows Server 2022: all versions
- Microsoft Windows 10 Version 1507: from 10.0.10240.0 before 10.0.10240.19325 — fixed in 10.0.10240.19325
- Microsoft Windows 10 1607: from 10.0.14393.0 before 10.0.14393.5192 — fixed in 10.0.14393.5192
- Microsoft Windows 10: from 10.0.17763.0 before 10.0.17763.3046 — fixed in 10.0.17763.3046
- Microsoft Windows 10 20H2: from 10.0.0 before 10.0.19042.1766 — fixed in 10.0.19042.1766
- Microsoft Windows 10 21H1: from 10.0.0 before 10.0.19043.1766 — fixed in 10.0.19043.1766
- Microsoft Windows 10: from 10.0.19043.0 before 10.0.19043.1766 — fixed in 10.0.19043.1766
- Microsoft Windows 11 21H2: from 10.0.0 before 10.0.22000.739 — fixed in 10.0.22000.739
- Microsoft Windows 7: from 6.1.0 before 6.1.7601.25984 — fixed in 6.1.7601.25984
- Microsoft Windows 7 Service Pack 1: from 6.1.0 before 6.1.7601.25984 — fixed in 6.1.7601.25984
- Microsoft Windows 8.1: from 6.3.0 before 6.3.9600.20402 — fixed in 6.3.9600.20402
- Microsoft Windows Server 2008 R2 Service Pack 1: from 6.1.7601.0 before 6.1.7601.25984 — fixed in 6.1.7601.25984
- Microsoft Windows Server 2008 Service Pack 2: from 6.0.6003.0 before 6.0.6003.21507 — fixed in 6.0.6003.21507
- Microsoft Windows Server 2012: from 6.2.9200.0 before 6.2.9200.23736 — fixed in 6.2.9200.23736
- Microsoft Windows Server 2012 R2: from 6.3.9600.0 before 6.3.9600.20402 — fixed in 6.3.9600.20402
- Microsoft Windows Server 2016: from 10.0.14393.0 before 10.0.14393.5192 — fixed in 10.0.14393.5192
- Microsoft Windows Server 2019: from 10.0.17763.0 before 10.0.17763.3046 — fixed in 10.0.17763.3046
- Microsoft Windows Server 2022: from 10.0.20348.0 before 10.0.20348.770 — fixed in 10.0.20348.770
- Microsoft Windows Server version 20H2: from 10.0.0 before 10.0.19042.1766 — fixed in 10.0.19042.1766
How to fix
Upgrade to a fixed version: Microsoft Windows 10 Version 1507 10.0.10240.19325; Microsoft Windows 10 1607 10.0.14393.5192; Microsoft Windows 10 10.0.17763.3046; Microsoft Windows 10 20H2 10.0.19042.1766; Microsoft Windows 10 21H1 10.0.19043.1766; Microsoft Windows 10 10.0.19043.1766; Microsoft Windows 11 21H2 10.0.22000.739; Microsoft Windows 7 6.1.7601.25984; Microsoft Windows 7 Service Pack 1 6.1.7601.25984; Microsoft Windows 8.1 6.3.9600.20402; Microsoft Windows Server 2008 R2 Service Pack 1 6.1.7601.25984; Microsoft Windows Server 2008 Service Pack 2 6.0.6003.21507. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-30141
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2022-30141
Get alerted when CVE-2022-30141 or the next vulnerability affects your stack