What’s Vulnerable › Vulnerabilities
CVE-2022-3016: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-28 · updated 2026-06-17
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0286.
Affected products
- Fedoraproject Fedora: 37
- vim/vim: before 9.0.0286 — fixed in 9.0.0286
How to fix
Upgrade to a fixed version: vim/vim 9.0.0286. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/6d24a51b94beb1991cddce221f90b455e2d50db7
- https://huntr.dev/bounties/260516c2-5c4a-4b7f-a01c-04b1aeeea371
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XWOJOA7PZZAMBI5GFTL6PWHXMWSDLUXL/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/6d24a51b94beb1991cddce221f90b455e2d50db7
- https://huntr.dev/bounties/260516c2-5c4a-4b7f-a01c-04b1aeeea371
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XWOJOA7PZZAMBI5GFTL6PWHXMWSDLUXL/
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-3016 or the next vulnerability affects your stack