What’s Vulnerable › Vulnerabilities

CVE-2022-3018

Description

An information disclosure vulnerability in GitLab CE/EE affecting all versions starting from 9.3 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1 allows a project maintainer to access the DataDog integration API key from webhook logs.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.2.5, 15.3.4, 15.4.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3018 or the next vulnerability affects your stack