What’s Vulnerable › Vulnerabilities
CVE-2022-30278
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-10 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in Black Duck Hub’s embedded MadCap Flare documentation files could allow an unauthenticated remote attacker to conduct a cross-site scripting attack. The vulnerability is due to improper validation of user-supplied input to MadCap Flare's framework embedded within Black Duck Hub's Help Documentation to supply content. An attacker could exploit this vulnerability by convincing a user to click a link designed to pass malicious input to the interface. A successful exploit could allow the attacker to conduct cross-site scripting attacks and gain access to sensitive browser-based information.
Affected products
- Synopsys Black Duck Hub: before 2022.4.0 — fixed in 2022.4.0
How to fix
Upgrade to a fixed version: Synopsys Black Duck Hub 2022.4.0. Check the vendor advisory for mitigations.
References
- https://www.synopsys.com/blogs/software-security/cyrc-advisory-cross-site-scripting-vulnerability-black-duck-hub/
- https://www.synopsys.com/blogs/software-security/cyrc-advisory-cross-site-scripting-vulnerability-black-duck-hub/
Get alerted when CVE-2022-30278 or the next vulnerability affects your stack