What’s Vulnerable › Vulnerabilities
CVE-2022-30303
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-78
Description
An improper neutralization of special elements used in an os command ('OS Command Injection') [CWE-78] in FortiWeb 7.0.0 through 7.0.1, 6.3.0 through 6.3.19, 6.4 all versions may allow an authenticated attacker to execute arbitrary shell code as `root` user via crafted HTTP requests.
Affected products
- Fortinet FortiWeb: from 6.3.0 before 6.3.20; 6.4.0, 6.4.1, 6.4.2, 7.0.0, 7.0.1 — fixed in 6.3.20
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 6.3.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-30303 or the next vulnerability affects your stack