What’s Vulnerable › Vulnerabilities

CVE-2022-3031

Description

An issue has been discovered in GitLab CE/EE affecting all versions before 15.1.6, all versions starting from 15.2 before 15.2.4, all versions starting from 15.3 before 15.3.2. It may be possible for an attacker to guess a user's password by brute force by sending crafted requests to a specific endpoint, even if the victim user has 2FA enabled on their account.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.1.6, 15.2.4, 15.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3031 or the next vulnerability affects your stack