What’s Vulnerable › Vulnerabilities
CVE-2022-3036: Gettext override translations < 2.0.0 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gettext override translations WordPress plugin before 2.0.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Gettext override translations: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Gettext override translations 2.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0dbc85dd-736c-492e-9db8-acb7195771aa
- https://wpscan.com/vulnerability/0dbc85dd-736c-492e-9db8-acb7195771aa
Get alerted when CVE-2022-3036 or the next vulnerability affects your stack