What’s Vulnerable › Vulnerabilities
CVE-2022-3037: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-30 · updated 2026-09-24
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0322.
Affected products
- Fedoraproject Fedora: 35, 36, 37
- Neovim: from 0.5.0 before 0.9.0 — fixed in 0.9.0
- vim/vim: before 9.0.0322 — fixed in 9.0.0322
How to fix
Upgrade to a fixed version: Neovim 0.9.0; vim/vim 9.0.0322. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/4f1b083be43f351bc107541e7b0c9655a5d2c0bb
- https://huntr.dev/bounties/af4c2f2d-d754-4607-b565-9e92f3f717b5
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RY3GEN2Q46ZJKSNHTN2XB6B3VAJBEILN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VHJ6LCLHGGVI2U6ZHXHTZ2PYP4STC23N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XWOJOA7PZZAMBI5GFTL6PWHXMWSDLUXL/
- https://github.com/vim/vim/commit/4f1b083be43f351bc107541e7b0c9655a5d2c0bb
- https://huntr.dev/bounties/af4c2f2d-d754-4607-b565-9e92f3f717b5
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RY3GEN2Q46ZJKSNHTN2XB6B3VAJBEILN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VHJ6LCLHGGVI2U6ZHXHTZ2PYP4STC23N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XWOJOA7PZZAMBI5GFTL6PWHXMWSDLUXL/
Get alerted when CVE-2022-3037 or the next vulnerability affects your stack