What’s Vulnerable › Vulnerabilities
CVE-2022-30429
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in Neos CMS allow attackers with the editor role or higher to inject arbitrary script or HTML code using the editor function, the deletion of assets, or a workspace title. The vulnerabilities were found in versions 3.3.29 and 8.0.1 and could also be present in all intermediate versions.
Affected products
- Neos Cms: from 3.3.0 before 5.3.10; from 7.0.0 before 7.0.9; from 7.1.0 before 7.1.7; from 7.2.0 before 7.2.6; from 7.3.0 before 7.3.4; from 8.0.0 before 8.0.2 — fixed in 5.3.10, 7.0.9, 7.1.7, 7.2.6, 7.3.4, 8.0.2
How to fix
Upgrade to a fixed version: Neos Cms 5.3.10, 7.0.9, 7.1.7, 7.2.6. Check the vendor advisory for mitigations.
References
- https://it-sec.de/unbekannte-schwachstellen-in-neos-cms/
- https://www.neos.io/blog/xss-in-various-backend-modules.html
- https://it-sec.de/unbekannte-schwachstellen-in-neos-cms/
- https://www.neos.io/blog/xss-in-various-backend-modules.html
Get alerted when CVE-2022-30429 or the next vulnerability affects your stack