What’s Vulnerable › Vulnerabilities
CVE-2022-30525: Zyxel Multiple Firewalls OS Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-05-16
- EPSS: 99.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-12 · updated 2026-06-17
- Weakness: CWE-78
Description
A OS command injection vulnerability in the CGI program of Zyxel USG FLEX 100(W) firmware versions 5.00 through 5.21 Patch 1, USG FLEX 200 firmware versions 5.00 through 5.21 Patch 1, USG FLEX 500 firmware versions 5.00 through 5.21 Patch 1, USG FLEX 700 firmware versions 5.00 through 5.21 Patch 1, USG FLEX 50(W) firmware versions 5.10 through 5.21 Patch 1, USG20(W)-VPN firmware versions 5.10 through 5.21 Patch 1, ATP series firmware versions 5.10 through 5.21 Patch 1, VPN series firmware versions 4.60 through 5.21 Patch 1, which could allow an attacker to modify specific files and then execute some OS commands on a vulnerable device.
Affected products
- Zyxel Atp100 Firmware: from 5.10 before 5.30 — fixed in 5.30
- Zyxel Atp100W Firmware: from 5.10 before 5.30 — fixed in 5.30
- Zyxel Atp200 Firmware: from 5.10 before 5.30 — fixed in 5.30
- Zyxel Atp500 Firmware: from 5.10 before 5.30 — fixed in 5.30
- Zyxel Atp700 Firmware: from 5.10 before 5.30 — fixed in 5.30
- Zyxel Atp800 Firmware: from 5.10 before 5.30 — fixed in 5.30
- Zyxel USG20(W)-VPN firmware: from 5.10 before 5.30 — fixed in 5.30
- Zyxel USG FLEX 100(W) firmware: from 5.00 before 5.30 — fixed in 5.30
- Zyxel USG FLEX 200 firmware: from 5.00 before 5.30 — fixed in 5.30
- Zyxel USG FLEX 500 firmware: from 5.00 through 5.30
- Zyxel USG FLEX 50(W) firmware: from 5.10 before 5.30 — fixed in 5.30
- Zyxel USG FLEX 700 firmware: from 5.00 before 5.30 — fixed in 5.30
- Zyxel Vpn1000 Firmware: from 4.60 before 5.30 — fixed in 5.30
- Zyxel Vpn100 Firmware: from 4.60 before 5.30 — fixed in 5.30
- Zyxel Vpn300 Firmware: from 4.60 before 5.30 — fixed in 5.30
- Zyxel Vpn50 Firmware: from 4.60 before 5.30 — fixed in 5.30
How to fix
Upgrade to a fixed version: Zyxel Atp100 Firmware 5.30; Zyxel Atp100W Firmware 5.30; Zyxel Atp200 Firmware 5.30; Zyxel Atp500 Firmware 5.30; Zyxel Atp700 Firmware 5.30; Zyxel Atp800 Firmware 5.30; Zyxel USG20(W)-VPN firmware 5.30; Zyxel USG FLEX 100(W) firmware 5.30; Zyxel USG FLEX 200 firmware 5.30; Zyxel USG FLEX 50(W) firmware 5.30; Zyxel USG FLEX 700 firmware 5.30; Zyxel Vpn1000 Firmware 5.30. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/167176/Zyxel-Remote-Command-Execution.html
- http://packetstormsecurity.com/files/167182/Zyxel-Firewall-ZTP-Unauthenticated-Command-Injection.html
- http://packetstormsecurity.com/files/167372/Zyxel-USG-FLEX-5.21-Command-Injection.html
- http://packetstormsecurity.com/files/168202/Zyxel-Firewall-SUID-Binary-Privilege-Escalation.html
- https://www.zyxel.com/support/Zyxel-security-advisory-for-OS-command-injection-vulnerability-of-firewalls.shtml
- http://packetstormsecurity.com/files/167176/Zyxel-Remote-Command-Execution.html
- http://packetstormsecurity.com/files/167182/Zyxel-Firewall-ZTP-Unauthenticated-Command-Injection.html
- http://packetstormsecurity.com/files/167372/Zyxel-USG-FLEX-5.21-Command-Injection.html
- http://packetstormsecurity.com/files/168202/Zyxel-Firewall-SUID-Binary-Privilege-Escalation.html
- https://www.zyxel.com/support/Zyxel-security-advisory-for-OS-command-injection-vulnerability-of-firewalls.shtml
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-30525
Get alerted when CVE-2022-30525 or the next vulnerability affects your stack