What’s Vulnerable › Vulnerabilities
CVE-2022-30532
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-19 · updated 2026-06-17
Description
In affected versions of Octopus Deploy, there is no logging of changes to artifacts within Octopus Deploy.
Affected products
- Octopus Deploy Octopus Server: from 0.9 before 2021.3.13021; from 2022.1.0 before 2022.1.2849; from 2022.3.348 before 2022.3.2387 — fixed in 2021.3.13021, 2022.1.2849, 2022.3.2387
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2021.3.13021, 2022.1.2849, 2022.3.2387. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-08/
- https://advisories.octopus.com/post/2022/sa2022-08/
Get alerted when CVE-2022-30532 or the next vulnerability affects your stack