What’s Vulnerable › Vulnerabilities
CVE-2022-30535: NGINX Ingress Controller vulnerability CVE-2022-30535
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-04 · updated 2026-06-17
- Weakness: CWE-20
Description
In versions 2.x before 2.3.0 and all versions of 1.x, An attacker authorized to create or update ingress objects can obtain the secrets available to the NGINX Ingress Controller. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Ingress Controller: from 1.0.0 before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: F5 NGINX Ingress Controller 2.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-30535 or the next vulnerability affects your stack