What’s Vulnerable › Vulnerabilities
CVE-2022-30536: WordPress WP Maintenance plugin <= 6.0.7 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Authenticated Stored Cross-Site Scripting (XSS) vulnerability in Florent Maillefaud's WP Maintenance plugin <= 6.0.7 at WordPress.
Affected products
- Florent Maillefaud WP Maintenance: before 6.0.8 — fixed in 6.0.8
How to fix
Upgrade to a fixed version: Florent Maillefaud WP Maintenance 6.0.8. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-maintenance/wordpress-wp-maintenance-plugin-6-0-7-authenticated-stored-cross-site-scripting-xss-vulnerability
- https://wordpress.org/plugins/wp-maintenance/#developers
- https://patchstack.com/database/vulnerability/wp-maintenance/wordpress-wp-maintenance-plugin-6-0-7-authenticated-stored-cross-site-scripting-xss-vulnerability
- https://wordpress.org/plugins/wp-maintenance/#developers
Get alerted when CVE-2022-30536 or the next vulnerability affects your stack