What’s Vulnerable › Vulnerabilities
CVE-2022-30557
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-11 · updated 2026-06-17
- Weakness: CWE-843
Description
Foxit PDF Reader and PDF Editor before 11.2.2 have a Type Confusion issue that causes a crash because of Unsigned32 mishandling during JavaScript execution.
Affected products
- Foxit PDF Reader: through 10.1.7.37777; from 11.0 before 11.2.2 — fixed in 11.2.2
- Foxit Pdf Reader: before 11.2.2 — fixed in 11.2.2
How to fix
Upgrade to a fixed version: Foxit PDF Reader 11.2.2; Foxit Pdf Reader 11.2.2. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.foxit.com/support/security-bulletins.html
Get alerted when CVE-2022-30557 or the next vulnerability affects your stack