What’s Vulnerable › Vulnerabilities
CVE-2022-30592
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-11 · updated 2026-06-17
- Weakness: CWE-476
Description
liblsquic/lsquic_qenc_hdl.c in LiteSpeed QUIC (aka LSQUIC) before 3.1.0 mishandles MAX_TABLE_CAPACITY.
Affected products
- litespeedtech LSQUIC: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: litespeedtech LSQUIC 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/litespeedtech/lsquic/commit/a74702c630e108125e71898398737baec8f02238#diff-73a138506faffe5f1efa8586346ab573c88e9dd2097774ecca5949a718a57cae
- https://github.com/litespeedtech/lsquic/releases/tag/v3.1.0
- https://github.com/litespeedtech/lsquic/commit/a74702c630e108125e71898398737baec8f02238#diff-73a138506faffe5f1efa8586346ab573c88e9dd2097774ecca5949a718a57cae
- https://github.com/litespeedtech/lsquic/releases/tag/v3.1.0
Get alerted when CVE-2022-30592 or the next vulnerability affects your stack