What’s Vulnerable › Vulnerabilities

CVE-2022-30594

Description

The Linux kernel before 5.17.2 mishandles seccomp permissions. The PTRACE_SEIZE code path allows attackers to bypass intended restrictions on setting the PT_SUSPEND_SECCOMP flag.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.19.238, 5.10.110, 5.15.33, 5.16.19. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-30594 or the next vulnerability affects your stack