What’s Vulnerable › Vulnerabilities
CVE-2022-30618
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-19 · updated 2026-06-17
- Weakness: CWE-212
Description
An authenticated user with access to the Strapi admin panel can view private and sensitive data, such as email and password reset tokens, for API users if content types accessible to the authenticated user contain relationships to API users (from:users-permissions). There are many scenarios in which such details from API users can leak in the JSON response within the admin panel, either through a direct or indirect relationship. Access to this information enables a user to compromise these users’ accounts if the password reset API endpoints have been enabled. In a worst-case scenario, a low-privileged user could get access to a high-privileged API account, and could read and modify any data as well as block access to both the admin panel and API by revoking privileges for all other users.
Affected products
- strapi: from 3.0.0 before 3.6.10; from 4.0.0 before 4.1.10 — fixed in 3.6.10, 4.1.10
How to fix
Upgrade to a fixed version: strapi 3.6.10, 4.1.10. Check the vendor advisory for mitigations.
References
- https://www.synopsys.com/blogs/software-security/cyrc-advisory-strapi
- https://www.synopsys.com/blogs/software-security/cyrc-advisory-strapi
Get alerted when CVE-2022-30618 or the next vulnerability affects your stack