What’s Vulnerable › Vulnerabilities

CVE-2022-30688

Description

needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.

Affected products

How to fix

Upgrade to a fixed version: needrestart 3.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-30688 or the next vulnerability affects your stack