What’s Vulnerable › Vulnerabilities
CVE-2022-3070: Generate PDF using Contact Form 7 < 3.6 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Generate PDF WordPress plugin before 3.6 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Generate PDF using Contact Form 7: before 3.6 — fixed in 3.6
How to fix
Upgrade to a fixed version: Generate PDF using Contact Form 7 3.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/cd8d71d1-030e-4ad4-866e-75d242883c6c
- https://wpscan.com/vulnerability/cd8d71d1-030e-4ad4-866e-75d242883c6c
Get alerted when CVE-2022-3070 or the next vulnerability affects your stack