What’s Vulnerable › Vulnerabilities
CVE-2022-30763
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-16 · updated 2026-06-17
- Weakness: CWE-129
Description
Janet before 1.22.0 mishandles arrays.
Affected products
- janet-lang janet: before 1.22.0 — fixed in 1.22.0
How to fix
Upgrade to a fixed version: janet-lang janet 1.22.0. Check the vendor advisory for mitigations.
References
- https://blog.convisoappsec.com/en/bug-hunting-in-the-janet-language-interpreter/
- https://github.com/janet-lang/janet/compare/v1.21.1...v1.22.0
- https://github.com/janet-lang/janet/releases/tag/v1.22.0
- https://blog.convisoappsec.com/en/bug-hunting-in-the-janet-language-interpreter/
- https://github.com/janet-lang/janet/compare/v1.21.1...v1.22.0
- https://github.com/janet-lang/janet/releases/tag/v1.22.0
Get alerted when CVE-2022-30763 or the next vulnerability affects your stack