What’s Vulnerable › Vulnerabilities
CVE-2022-30792: CODESYS: CmpChannelServer, CmpChannelServerEmbedded allow unauthenticated attackers to block all their available communication channels
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-11 · updated 2026-06-17
- Weakness: CWE-400
Description
In CmpChannelServer of CODESYS V3 in multiple versions an uncontrolled ressource consumption allows an unauthorized attacker to block new communication channel connections. Existing connections are not affected.
Affected products
- CODESYS Control for BeagleBone: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control For Empc-A/Imx6: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control for IOT2000 SL: before 4.6.0.0 — fixed in 4.6.0.0
- CODESYS Control for Linux SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control for PFC100 SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control for PFC200 SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control For Plcnext: before 4.6.0.0 — fixed in 4.6.0.0
- CODESYS Control for Raspberry Pi SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control For Wago Touch Panels 600: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control RTE (SL): before 3.5.18.20 — fixed in 3.5.18.20
- CODESYS Control Rte Sl (For Beckhoff Cx): before 3.5.18.20 — fixed in 3.5.18.20
- CODESYS Control Runtime System Toolkit: before 3.5.18.20 — fixed in 3.5.18.20
- CODESYS Control Win: before 3.5.18.20 — fixed in 3.5.18.20
- CODESYS Development System: before 3.5.18.20 — fixed in 3.5.18.20
- CODESYS Edge Gateway: before 3.5.18.20; before 4.5.0.0 — fixed in 3.5.18.20, 4.5.0.0
- CODESYS Embedded Target Visu Toolkit: before 3.5.18.20 — fixed in 3.5.18.20
- CODESYS Gateway Server V2: before 3.5.18.20 — fixed in 3.5.18.20
- CODESYS Hmi: before 3.5.18.20 — fixed in 3.5.18.20
- CODESYS Remote Target Visu Toolkit: before 3.5.18.20 — fixed in 3.5.18.20
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone 4.5.0.0; CODESYS Control For Empc-A/Imx6 4.5.0.0; CODESYS Control for IOT2000 SL 4.6.0.0; CODESYS Control for Linux SL 4.5.0.0; CODESYS Control for PFC100 SL 4.5.0.0; CODESYS Control for PFC200 SL 4.5.0.0; CODESYS Control For Plcnext 4.6.0.0; CODESYS Control for Raspberry Pi SL 4.5.0.0; CODESYS Control For Wago Touch Panels 600 4.5.0.0; CODESYS Control RTE (SL) 3.5.18.20; CODESYS Control Rte Sl (For Beckhoff Cx) 3.5.18.20; CODESYS Control Runtime System Toolkit 3.5.18.20. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17128&token=bee4d8a57f19be289d623ec90135493b5f9179e3&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17128&token=bee4d8a57f19be289d623ec90135493b5f9179e3&download=
Get alerted when CVE-2022-30792 or the next vulnerability affects your stack