What’s Vulnerable › Vulnerabilities
CVE-2022-30950
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-17 · updated 2026-06-17
- Weakness: CWE-120
Description
Jenkins WMI Windows Agents Plugin 1.8 and earlier includes the Windows Remote Command library which has a buffer overflow vulnerability that may allow users able to connect to a named pipe to execute commands on the Windows agent machine.
Affected products
- Jenkins project Jenkins WMI Windows Agents Plugin: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: Jenkins project Jenkins WMI Windows Agents Plugin 1.8.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/05/17/8
- https://www.jenkins.io/security/advisory/2022-05-17/#SECURITY-2604
- http://www.openwall.com/lists/oss-security/2022/05/17/8
- https://www.jenkins.io/security/advisory/2022-05-17/#SECURITY-2604
Get alerted when CVE-2022-30950 or the next vulnerability affects your stack