What’s Vulnerable › Vulnerabilities
CVE-2022-3099: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-03 · updated 2026-06-17
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0360.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36, 37
- vim/vim: before 9.0.0360 — fixed in 9.0.0360
How to fix
Upgrade to a fixed version: vim/vim 9.0.0360. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/35d21c6830fc2d68aca838424a0e786821c5891c
- https://huntr.dev/bounties/403210c7-6cc7-4874-8934-b57f88bd4f5e
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DVWBI4BVTBUMNW4NMB3WZZDQJBKIGXI3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LLK2RMZEECKKWUQK7J46D2FQZOXFQLTC/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XWOJOA7PZZAMBI5GFTL6PWHXMWSDLUXL/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/35d21c6830fc2d68aca838424a0e786821c5891c
- https://huntr.dev/bounties/403210c7-6cc7-4874-8934-b57f88bd4f5e
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DVWBI4BVTBUMNW4NMB3WZZDQJBKIGXI3/
Get alerted when CVE-2022-3099 or the next vulnerability affects your stack