What’s Vulnerable › Vulnerabilities
CVE-2022-31000: CSRF allows attacker to finalize/unfinalize order adjustments in solidus_backend
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-01 · updated 2026-06-17
- Weakness: CWE-352
Description
solidus_backend is the admin interface for the Solidus e-commerce framework. Versions prior to 3.1.6, 3.0.6, and 2.11.16 contain a cross-site request forgery (CSRF) vulnerability. The vulnerability allows attackers to change the state of an order's adjustments if they hold its number, and the execution happens on a store administrator's computer. Users should upgrade to solidus_backend 3.1.6, 3.0.6, or 2.11.16 to receive a patch.
Affected products
- solidusio solidus: before 2.11.16; from 3.0.0 before 3.0.5; from 3.1.0 before 3.1.6 — fixed in 2.11.16, 3.0.5, 3.1.6
How to fix
Upgrade to a fixed version: solidusio solidus 2.11.16, 3.0.5, 3.1.6. Check the vendor advisory for mitigations.
References
- https://github.com/solidusio/solidus/commit/de796a2e0be7f154cae48b46e267501559d9716c
- https://github.com/solidusio/solidus/security/advisories/GHSA-8639-qx56-r428
- https://github.com/solidusio/solidus/commit/de796a2e0be7f154cae48b46e267501559d9716c
- https://github.com/solidusio/solidus/security/advisories/GHSA-8639-qx56-r428
Get alerted when CVE-2022-31000 or the next vulnerability affects your stack