What’s Vulnerable › Vulnerabilities
CVE-2022-31001: Out-of-bounds Read in Sofia-SIP
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-31 · updated 2026-06-17
- Weakness: CWE-125
Description
Sofia-SIP is an open-source Session Initiation Protocol (SIP) User-Agent library. Prior to version 1.13.8, an attacker can send a message with evil sdp to FreeSWITCH, which may cause crash. This type of crash may be caused by `#define MATCH(s, m) (strncmp(s, m, n = sizeof(m) - 1) == 0)`, which will make `n` bigger and trigger out-of-bound access when `IS_NON_WS(s[n])`. Version 1.13.8 contains a patch for this issue.
Affected products
- Debian Linux: 10.0, 11.0
- freeswitch sofia-sip: before 1.13.8 — fixed in 1.13.8
How to fix
Upgrade to a fixed version: freeswitch sofia-sip 1.13.8. Check the vendor advisory for mitigations.
References
- https://github.com/freeswitch/sofia-sip/commit/a99804b336d0e16d26ab7119d56184d2d7110a36
- https://github.com/freeswitch/sofia-sip/security/advisories/GHSA-79jq-hh82-cv9g
- https://lists.debian.org/debian-lts-announce/2022/09/msg00001.html
- https://security.gentoo.org/glsa/202210-18
- https://www.debian.org/security/2023/dsa-5410
- https://github.com/freeswitch/sofia-sip/commit/a99804b336d0e16d26ab7119d56184d2d7110a36
- https://github.com/freeswitch/sofia-sip/security/advisories/GHSA-79jq-hh82-cv9g
- https://lists.debian.org/debian-lts-announce/2022/09/msg00001.html
- https://security.gentoo.org/glsa/202210-18
- https://www.debian.org/security/2023/dsa-5410
Get alerted when CVE-2022-31001 or the next vulnerability affects your stack