What’s Vulnerable › Vulnerabilities
CVE-2022-31002: Out-of-bounds Read in Sofia-SIP
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-31 · updated 2026-06-17
- Weakness: CWE-125
Description
Sofia-SIP is an open-source Session Initiation Protocol (SIP) User-Agent library. Prior to version 1.13.8, an attacker can send a message with evil sdp to FreeSWITCH, which may cause a crash. This type of crash may be caused by a URL ending with `%`. Version 1.13.8 contains a patch for this issue.
Affected products
- Debian Linux: 10.0
- freeswitch sofia-sip: before 1.13.8 — fixed in 1.13.8
How to fix
Upgrade to a fixed version: freeswitch sofia-sip 1.13.8. Check the vendor advisory for mitigations.
References
- https://github.com/freeswitch/sofia-sip/commit/51841eb53679434a386fb2dcbca925dcc48d58ba
- https://github.com/freeswitch/sofia-sip/security/advisories/GHSA-g3x6-p824-x6hm
- https://lists.debian.org/debian-lts-announce/2022/09/msg00001.html
- https://security.gentoo.org/glsa/202210-18
- https://www.debian.org/security/2023/dsa-5410
- https://github.com/freeswitch/sofia-sip/commit/51841eb53679434a386fb2dcbca925dcc48d58ba
- https://github.com/freeswitch/sofia-sip/security/advisories/GHSA-g3x6-p824-x6hm
- https://lists.debian.org/debian-lts-announce/2022/09/msg00001.html
- https://security.gentoo.org/glsa/202210-18
- https://www.debian.org/security/2023/dsa-5410
Get alerted when CVE-2022-31002 or the next vulnerability affects your stack