What’s Vulnerable › Vulnerabilities
CVE-2022-31003: Heap-based Buffer Overflow and Out-of-bounds Write in Sofia-SIP
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-31 · updated 2026-06-17
- Weakness: CWE-122
Description
Sofia-SIP is an open-source Session Initiation Protocol (SIP) User-Agent library. Prior to version 1.13.8, when parsing each line of a sdp message, `rest = record + 2` will access the memory behind `\0` and cause an out-of-bounds write. An attacker can send a message with evil sdp to FreeSWITCH, causing a crash or more serious consequence, such as remote code execution. Version 1.13.8 contains a patch for this issue.
Affected products
- Debian Linux: 10.0
- freeswitch sofia-sip: before 1.13.8 — fixed in 1.13.8
How to fix
Upgrade to a fixed version: freeswitch sofia-sip 1.13.8. Check the vendor advisory for mitigations.
References
- https://github.com/freeswitch/sofia-sip/commit/907f2ac0ee504c93ebfefd676b4632a3575908c9
- https://github.com/freeswitch/sofia-sip/security/advisories/GHSA-8w5j-6g2j-pxcp
- https://lists.debian.org/debian-lts-announce/2022/09/msg00001.html
- https://security.gentoo.org/glsa/202210-18
- https://www.debian.org/security/2023/dsa-5410
- https://github.com/freeswitch/sofia-sip/commit/907f2ac0ee504c93ebfefd676b4632a3575908c9
- https://github.com/freeswitch/sofia-sip/security/advisories/GHSA-8w5j-6g2j-pxcp
- https://lists.debian.org/debian-lts-announce/2022/09/msg00001.html
- https://security.gentoo.org/glsa/202210-18
- https://www.debian.org/security/2023/dsa-5410
Get alerted when CVE-2022-31003 or the next vulnerability affects your stack