What’s Vulnerable › Vulnerabilities
CVE-2022-31005: Integer Overflow in Vapor's HTTP Range Request
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-31 · updated 2026-06-17
- Weakness: CWE-190
Description
Vapor is an HTTP web framework for Swift. Users of Vapor prior to version 4.60.3 with FileMiddleware enabled are vulnerable to an integer overflow vulnerability that can crash the application. Version 4.60.3 contains a patch for this issue. As a workaround, disable FileMiddleware and serve via a Content Delivery Network.
Affected products
- vapor: before 4.60.3 — fixed in 4.60.3
How to fix
Upgrade to a fixed version: vapor 4.60.3. Check the vendor advisory for mitigations.
References
- https://github.com/vapor/vapor/commit/953a349b539b3e0d3653585c8ffb50c427986df1
- https://github.com/vapor/vapor/releases/tag/4.60.3
- https://github.com/vapor/vapor/security/advisories/GHSA-vj2m-9f5j-mpr5
- https://github.com/vapor/vapor/commit/953a349b539b3e0d3653585c8ffb50c427986df1
- https://github.com/vapor/vapor/releases/tag/4.60.3
- https://github.com/vapor/vapor/security/advisories/GHSA-vj2m-9f5j-mpr5
Get alerted when CVE-2022-31005 or the next vulnerability affects your stack