What’s Vulnerable › Vulnerabilities
CVE-2022-31008: Predictable credential obfuscation seed value used in rabbitmq-server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-06 · updated 2026-06-17
- Weakness: CWE-330
Description
RabbitMQ is a multi-protocol messaging and streaming broker. In affected versions the shovel and federation plugins perform URI obfuscation in their worker (link) state. The encryption key used to encrypt the URI was seeded with a predictable secret. This means that in case of certain exceptions related to Shovel and Federation plugins, reasonably easily deobfuscatable data could appear in the node log. Patched versions correctly use a cluster-wide secret for that purpose. This issue has been addressed and Patched versions: `3.10.2`, `3.9.18`, `3.8.32` are available. Users unable to upgrade should disable the Shovel and Federation plugins.
Affected products
- rabbitmq-server: from 3.9.0 before 3.9.18; from 3.10.0 before 3.10.2 — fixed in 3.10.2, 3.9.18
- VMware Tanzu RabbitMQ: before 3.8.32 — fixed in 3.8.32
- rabbitmq-server: before 3.8.32; from 3.9.0, < 3.9.18; from 3.10.0, < 3.10.2
How to fix
Upgrade to a fixed version: rabbitmq-server 3.10.2, 3.9.18; VMware Tanzu RabbitMQ 3.8.32. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/pull/4841
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-v9gv-xp36-jgj8
- https://github.com/rabbitmq/rabbitmq-server/pull/4841
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-v9gv-xp36-jgj8
Get alerted when CVE-2022-31008 or the next vulnerability affects your stack