What’s Vulnerable › Vulnerabilities
CVE-2022-31015: Uncaught Exception (due to a data race) leads to process termination in Waitress
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-31 · updated 2026-06-17
- Weakness: CWE-248
Description
Waitress is a Web Server Gateway Interface server for Python 2 and 3. Waitress versions 2.1.0 and 2.1.1 may terminate early due to a thread closing a socket while the main thread is about to call select(). This will lead to the main thread raising an exception that is not handled and then causing the entire application to be killed. This issue has been fixed in Waitress 2.1.2 by no longer allowing the WSGI thread to close the socket. Instead, that is always delegated to the main thread. There is no work-around for this issue. However, users using waitress behind a reverse proxy server are less likely to have issues if the reverse proxy always reads the full response.
Affected products
- Pylons Waitress: from 2.1.0 before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Pylons Waitress 2.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/Pylons/waitress/commit/4f6789b035610e0552738cdc4b35ca809a592d48
- https://github.com/Pylons/waitress/issues/374
- https://github.com/Pylons/waitress/pull/377
- https://github.com/Pylons/waitress/security/advisories/GHSA-f5x9-8jwc-25rw
- https://github.com/Pylons/waitress/commit/4f6789b035610e0552738cdc4b35ca809a592d48
- https://github.com/Pylons/waitress/issues/374
- https://github.com/Pylons/waitress/pull/377
- https://github.com/Pylons/waitress/security/advisories/GHSA-f5x9-8jwc-25rw
Get alerted when CVE-2022-31015 or the next vulnerability affects your stack