What’s Vulnerable › Vulnerabilities
CVE-2022-31016: Argo CD vulnerable to Uncontrolled Memory Consumption
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-25 · updated 2026-06-17
- Weakness: CWE-400
Description
Argo CD is a declarative continuous deployment for Kubernetes. Argo CD versions v0.7.0 and later are vulnerable to an uncontrolled memory consumption bug, allowing an authorized malicious user to crash the repo-server service, resulting in a Denial of Service. The attacker must be an authenticated Argo CD user authorized to deploy Applications from a repository which contains (or can be made to contain) a large file. The fix for this vulnerability is available in versions 2.3.5, 2.2.10, 2.1.16, and later. There are no known workarounds. Users are recommended to upgrade.
Affected products
- argoproj argo-cd: from 0.7.0 before 2.1.16; from 2.2.0 before 2.2.10; from 2.3.0 before 2.3.5; from 2.4.0 before 2.4.1 — fixed in 2.1.16, 2.2.10, 2.3.5, 2.4.1
How to fix
Upgrade to a fixed version: argoproj argo-cd 2.1.16, 2.2.10, 2.3.5, 2.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/argoproj/argo-cd/security/advisories/GHSA-jhqp-vf4w-rpwq
- https://github.com/argoproj/argo-cd/security/advisories/GHSA-jhqp-vf4w-rpwq
Get alerted when CVE-2022-31016 or the next vulnerability affects your stack