What’s Vulnerable › Vulnerabilities
CVE-2022-31017: Expression Always True vulnerability in Zulip Server
- Severity: low (CVSS 2.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-25 · updated 2026-06-17
- Weakness: CWE-571
Description
Zulip is an open-source team collaboration tool. Versions 2.1.0 through and including 5.2 are vulnerable to a logic error. A stream configured as private with protected history, where new subscribers should not be allowed to see messages sent before they were subscribed, when edited causes the server to incorrectly send an API event that includes the edited message to all of the stream’s current subscribers. This API event is ignored by official clients, but can be observed by using a modified client or the browser’s developer tools. This bug will be fixed in Zulip Server 5.3. There are no known workarounds.
Affected products
- zulip: from 2.1.0 before 5.3 — fixed in 5.3
How to fix
Upgrade to a fixed version: zulip 5.3. Check the vendor advisory for mitigations.
References
- https://github.com/zulip/zulip/security/advisories/GHSA-m5j3-jp59-6f3q
- https://github.com/zulip/zulip/security/advisories/GHSA-m5j3-jp59-6f3q
Get alerted when CVE-2022-31017 or the next vulnerability affects your stack