What’s Vulnerable › Vulnerabilities
CVE-2022-31030: containerd CRI plugin: Host memory exhaustion through ExecSync
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-09 · updated 2026-06-17
- Weakness: CWE-400
Description
containerd is an open source container runtime. A bug was found in the containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the `ExecSync` API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; `ExecSync` may be used when running probes or when executing processes via an "exec" facility. This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used.
Affected products
- Debian Linux: 11.0
- Fedoraproject Fedora: 35, 36
- containerd: before 1.5.13; from 1.6.0 before 1.6.6 — fixed in 1.5.13, 1.6.6
How to fix
Upgrade to a fixed version: containerd 1.5.13, 1.6.6. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/06/07/1
- https://github.com/containerd/containerd/commit/c1bcabb4541930f643aa36a2b38655e131346382
- https://github.com/containerd/containerd/security/advisories/GHSA-5ffw-gxpp-mxpf
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/REOZCUAPCA7NFDWYBDYX6EYXWLHABKBO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WSIGDBHAB3I75JBJNGWEPBTJPS2FOVHD/
- https://security.gentoo.org/glsa/202401-31
- https://www.debian.org/security/2022/dsa-5162
- http://www.openwall.com/lists/oss-security/2022/06/07/1
- https://github.com/containerd/containerd/commit/c1bcabb4541930f643aa36a2b38655e131346382
- https://github.com/containerd/containerd/security/advisories/GHSA-5ffw-gxpp-mxpf
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/REOZCUAPCA7NFDWYBDYX6EYXWLHABKBO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WSIGDBHAB3I75JBJNGWEPBTJPS2FOVHD/
Get alerted when CVE-2022-31030 or the next vulnerability affects your stack