What’s Vulnerable › Vulnerabilities
CVE-2022-31037: OroCommerce vulnerable to Cross-site Scripting via Shipping rule editing page
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
OroCommerce is an open-source Business to Business Commerce application. Versions between 4.1.0 and 4.1.17 inclusive, 4.2.0 and 4.2.11 inclusive, and between 5.0.0 and 5.0.3 inclusive, are vulnerable to Cross-site Scripting in the UPS Surcharge field of the Shipping rule edit page. The attacker needs permission to create or edit a shipping rule. This issue has been patched in version 5.0.6. There are no known workarounds.
Affected products
- oroinc orocommerce: from 4.1.0 through 4.1.17; from 4.2.0 through 4.2.11; from 5.0.0 through 5.0.3
References
- https://github.com/oroinc/orocommerce/security/advisories/GHSA-4vf4-955g-vxp2
- https://github.com/oroinc/orocommerce/security/advisories/GHSA-4vf4-955g-vxp2
Get alerted when CVE-2022-31037 or the next vulnerability affects your stack