What’s Vulnerable › Vulnerabilities
CVE-2022-31043: Fix failure to strip Authorization header on HTTP downgrade in Guzzle
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-10 · updated 2026-06-17
- Weakness: CWE-200
Description
Guzzle is an open source PHP HTTP client. In affected versions `Authorization` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, we should not forward the `Authorization` header on. This is much the same as to how we don't forward on the header if the host changes. Prior to this fix, `https` to `http` downgrades did not result in the `Authorization` header being removed, only changes to the host. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach which would be to use their own redirect middleware. Alternately users may simply disable redirects all together if redirects are not expected or required.
Affected products
- Debian Linux: 11.0
- Drupal: from 9.2.0 before 9.2.21; from 9.3.0 before 9.3.16; 9.4.0-alpha1, 9.4.0-beta1, 9.4.0-rc1 — fixed in 9.2.21, 9.3.16
- guzzle: before 6.5.7; from 7.0.0 before 7.4.4 — fixed in 6.5.7, 7.4.4
How to fix
Upgrade to a fixed version: Drupal 9.2.21, 9.3.16; guzzle 6.5.7, 7.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/guzzle/guzzle/commit/e3ff079b22820c2029d4c2a87796b6a0b8716ad8
- https://github.com/guzzle/guzzle/security/advisories/GHSA-w248-ffj2-4v5q
- https://www.debian.org/security/2022/dsa-5246
- https://www.drupal.org/sa-core-2022-011
- https://www.rfc-editor.org/rfc/rfc9110.html#name-redirection-3xx
- https://github.com/guzzle/guzzle/commit/e3ff079b22820c2029d4c2a87796b6a0b8716ad8
- https://github.com/guzzle/guzzle/security/advisories/GHSA-w248-ffj2-4v5q
- https://www.debian.org/security/2022/dsa-5246
- https://www.drupal.org/sa-core-2022-011
- https://www.rfc-editor.org/rfc/rfc9110.html#name-redirection-3xx
Get alerted when CVE-2022-31043 or the next vulnerability affects your stack