What’s Vulnerable › Vulnerabilities
CVE-2022-31048: Cross-Site Scripting in Form Framework
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-14 · updated 2026-06-17
- Weakness: CWE-79
Description
TYPO3 is an open source web content management system. Prior to versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. TYPO3 versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.
Affected products
- typo3: from 8.0.0 before 8.7.47; from 9.0.0 before 9.5.35; from 10.0.0 before 10.4.29; from 11.0.0 before 11.5.11 — fixed in 10.4.29, 11.5.11, 8.7.47, 9.5.35
How to fix
Upgrade to a fixed version: typo3 10.4.29, 11.5.11, 8.7.47, 9.5.35. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/typo3/commit/6f2554dc4ea0b670fd5599c54fd788d4db96c4a0
- https://github.com/TYPO3/typo3/security/advisories/GHSA-3r95-23jp-mhvg
- https://typo3.org/security/advisory/typo3-core-sa-2022-003
- https://github.com/TYPO3/typo3/commit/6f2554dc4ea0b670fd5599c54fd788d4db96c4a0
- https://github.com/TYPO3/typo3/security/advisories/GHSA-3r95-23jp-mhvg
- https://typo3.org/security/advisory/typo3-core-sa-2022-003
Get alerted when CVE-2022-31048 or the next vulnerability affects your stack