What’s Vulnerable › Vulnerabilities
CVE-2022-31049: Cross-Site Scripting in Frontend Login Mailer
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-14 · updated 2026-06-17
- Weakness: CWE-79
Description
TYPO3 is an open source web content management system. Prior to versions 9.5.34 ELTS, 10.4.29, and 11.5.11, user submitted content was used without being properly encoded in HTML emails sent to users. The actually affected components were mail clients used to view those messages. TYPO3 versions 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.
Affected products
- typo3: from 9.0.0 before 9.5.35; from 10.0.0 before 10.4.29; from 11.0.0 before 11.5.11 — fixed in 10.4.29, 11.5.11, 9.5.35
How to fix
Upgrade to a fixed version: typo3 10.4.29, 11.5.11, 9.5.35. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/typo3/commit/da611775f92102d7602713003f4c79606c8a445d
- https://github.com/TYPO3/typo3/security/advisories/GHSA-h4mx-xv96-2jgm
- https://typo3.org/security/advisory/typo3-core-sa-2022-004
- https://github.com/TYPO3/typo3/commit/da611775f92102d7602713003f4c79606c8a445d
- https://github.com/TYPO3/typo3/security/advisories/GHSA-h4mx-xv96-2jgm
- https://typo3.org/security/advisory/typo3-core-sa-2022-004
Get alerted when CVE-2022-31049 or the next vulnerability affects your stack