What’s Vulnerable › Vulnerabilities
CVE-2022-3105
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-14 · updated 2026-06-17
- Weakness: CWE-476
Description
An issue was discovered in the Linux kernel through 5.16-rc6. uapi_finalize in drivers/infiniband/core/uverbs_uapi.c lacks check of kmalloc_array().
Affected products
- Linux kernel: before 5.16.0; 5.16.0, 5.16.0-rc1, 5.16.0-rc2, 5.16.0-rc3, 5.16.0-rc4, 5.16.0-rc5 (+1) — fixed in 5.16.0
How to fix
Upgrade to a fixed version: Linux kernel 5.16.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2153067
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?h=v5.19-rc2&id=7694a7de22c53a312ea98960fcafc6ec62046531
- https://bugzilla.redhat.com/show_bug.cgi?id=2153067
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?h=v5.19-rc2&id=7694a7de22c53a312ea98960fcafc6ec62046531
Get alerted when CVE-2022-3105 or the next vulnerability affects your stack