What’s Vulnerable › Vulnerabilities
CVE-2022-31050: Insufficient Session Expiration in TYPO3 Admin Tool
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-14 · updated 2026-06-17
- Weakness: CWE-613
Description
TYPO3 is an open source web content management system. Prior to versions 9.5.34 ELTS, 10.4.29, and 11.5.11, Admin Tool sessions initiated via the TYPO3 backend user interface had not been revoked even if the corresponding user account was degraded to lower permissions or disabled completely. This way, sessions in the admin tool theoretically could have been prolonged without any limit. TYPO3 versions 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.
Affected products
- typo3: from 9.0.0 before 9.5.35; from 10.0.0 before 10.4.29; from 11.0.0 before 11.5.11 — fixed in 10.4.29, 11.5.11, 9.5.35
How to fix
Upgrade to a fixed version: typo3 10.4.29, 11.5.11, 9.5.35. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/typo3/commit/592387972912290c135ebecc91768a67f83a3a4d
- https://github.com/TYPO3/typo3/security/advisories/GHSA-wwjw-r3gj-39fq
- https://typo3.org/security/advisory/typo3-core-sa-2022-005
- https://github.com/TYPO3/typo3/commit/592387972912290c135ebecc91768a67f83a3a4d
- https://github.com/TYPO3/typo3/security/advisories/GHSA-wwjw-r3gj-39fq
- https://typo3.org/security/advisory/typo3-core-sa-2022-005
Get alerted when CVE-2022-31050 or the next vulnerability affects your stack