What’s Vulnerable › Vulnerabilities
CVE-2022-31051: Exposure of Sensitive Information to an Unauthorized Actor in semantic-release
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-09 · updated 2026-06-17
- Weakness: CWE-200
Description
semantic-release is an open source npm package for automated version management and package publishing. In affected versions secrets that would normally be masked by semantic-release can be accidentally disclosed if they contain characters that are excluded from uri encoding by `encodeURI`. Occurrence is further limited to execution contexts where push access to the related repository is not available without modifying the repository url to inject credentials. Users are advised to upgrade. Users unable to upgrade should ensure that secrets that do not contain characters that are excluded from encoding with `encodeURI` when included in a URL are already masked properly.
Affected products
- semantic-release: from 17.0.4 before 19.0.3 — fixed in 19.0.3
How to fix
Upgrade to a fixed version: semantic-release 19.0.3. Check the vendor advisory for mitigations.
References
- https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/encodeURI
- https://github.com/semantic-release/semantic-release/commit/58a226f29c04ee56bbb02cc661f020d568849cad
- https://github.com/semantic-release/semantic-release/releases/tag/v19.0.3
- https://github.com/semantic-release/semantic-release/security/advisories/GHSA-x2pg-mjhr-2m5x
- https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/encodeURI
- https://github.com/semantic-release/semantic-release/commit/58a226f29c04ee56bbb02cc661f020d568849cad
- https://github.com/semantic-release/semantic-release/releases/tag/v19.0.3
- https://github.com/semantic-release/semantic-release/security/advisories/GHSA-x2pg-mjhr-2m5x
Get alerted when CVE-2022-31051 or the next vulnerability affects your stack