What’s Vulnerable › Vulnerabilities
CVE-2022-31054: Uses of deprecated API can be used to cause DoS in user-facing endpoints in Argo Events
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-13 · updated 2026-06-17
- Weakness: CWE-400
Description
Argo Events is an event-driven workflow automation framework for Kubernetes. Prior to version 1.7.1, several `HandleRoute` endpoints make use of the deprecated `ioutil.ReadAll()`. `ioutil.ReadAll()` reads all the data into memory. As such, an attacker who sends a large request to the Argo Events server will be able to crash it and cause denial of service. A patch for this vulnerability has been released in Argo Events version 1.7.1.
Affected products
- argoproj argo-events: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: argoproj argo-events 1.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/argoproj/argo-events/commit/eaabcb6d65022fc34a0cc9ea7f00681abd326b35
- https://github.com/argoproj/argo-events/issues/1946
- https://github.com/argoproj/argo-events/pull/1966
- https://github.com/argoproj/argo-events/security/advisories/GHSA-5q86-62xr-3r57
- https://github.com/argoproj/argo-events/commit/eaabcb6d65022fc34a0cc9ea7f00681abd326b35
- https://github.com/argoproj/argo-events/issues/1946
- https://github.com/argoproj/argo-events/pull/1966
- https://github.com/argoproj/argo-events/security/advisories/GHSA-5q86-62xr-3r57
Get alerted when CVE-2022-31054 or the next vulnerability affects your stack