What’s Vulnerable › Vulnerabilities
CVE-2022-31056: SQL injection with _actor parameter in GLPI
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-28 · updated 2026-06-17
- Weakness: CWE-89
Description
GLPI is a Free Asset and IT Management Software package, Data center management, ITIL Service Desk, licenses tracking and software auditing. In affected versions all assistance forms (Ticket/Change/Problem) permit sql injection on the actor fields. This issue has been resolved in version 10.0.2 and all affected users are advised to upgrade.
Affected products
- glpi-project glpi: from 10.0.0 before 10.0.2 — fixed in 10.0.2
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/171656/GLPI-10.0.2-SQL-Injection-Remote-Code-Execution.html
- https://github.com/glpi-project/glpi/security/advisories/GHSA-9q9x-7xxh-w4cg
- http://packetstormsecurity.com/files/171656/GLPI-10.0.2-SQL-Injection-Remote-Code-Execution.html
- https://github.com/glpi-project/glpi/security/advisories/GHSA-9q9x-7xxh-w4cg
Get alerted when CVE-2022-31056 or the next vulnerability affects your stack