What’s Vulnerable › Vulnerabilities
CVE-2022-31057: Authenticated Stored XSS in Shopware Administration
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Shopware is an open source e-commerce software made in Germany. Versions of Shopware 5 prior to version 5.7.12 are subject to an authenticated Stored XSS in Administration. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- shopware: from 5.0.0 before 5.7.12 — fixed in 5.7.12
How to fix
Upgrade to a fixed version: shopware 5.7.12. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2022
- https://github.com/shopware/shopware/commit/3e025a0a3e123f4108082645b1ced6fb548f7b6f
- https://github.com/shopware/shopware/security/advisories/GHSA-q754-vwc4-p6qj
- https://packagist.org/packages/shopware/shopware
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2022
- https://github.com/shopware/shopware/commit/3e025a0a3e123f4108082645b1ced6fb548f7b6f
- https://github.com/shopware/shopware/security/advisories/GHSA-q754-vwc4-p6qj
- https://packagist.org/packages/shopware/shopware
Get alerted when CVE-2022-31057 or the next vulnerability affects your stack