What’s Vulnerable › Vulnerabilities
CVE-2022-31059: Discourse Calendar Event names susceptible to Cross-site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse Calendar is a calendar plugin for Discourse, an open-source messaging app. Prior to version 1.0.1, parsing and rendering of Event names can be susceptible to cross-site scripting (XSS) attacks. This vulnerability only affects sites which have modified or disabled Discourse’s default Content Security Policy. This issue is patched in version 1.0.1 of the Discourse Calendar plugin. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.
Affected products
- Discourse Calendar: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Discourse Calendar 1.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse-calendar/commit/2719b9e81994e961bf8c4e12b4556dc9777dd62f
- https://github.com/discourse/discourse-calendar/pull/280
- https://github.com/discourse/discourse-calendar/security/advisories/GHSA-c783-x9vm-xxp5
- https://github.com/discourse/discourse-calendar/commit/2719b9e81994e961bf8c4e12b4556dc9777dd62f
- https://github.com/discourse/discourse-calendar/pull/280
- https://github.com/discourse/discourse-calendar/security/advisories/GHSA-c783-x9vm-xxp5
Get alerted when CVE-2022-31059 or the next vulnerability affects your stack