What’s Vulnerable › Vulnerabilities
CVE-2022-31060: Banner topic data is exposed on login-required Discourse sites
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-14 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open-source discussion platform. Prior to version 2.8.4 in the `stable` branch and version `2.9.0.beta5` in the `beta` and `tests-passed` branches, banner topic data is exposed on login-required sites. This issue is patched in version 2.8.4 in the `stable` branch and version `2.9.0.beta5` in the `beta` and `tests-passed` branches of Discourse. As a workaround, one may disable banners.
Affected products
- discourse: before 2.8.4; 2.9.0-beta1, 2.9.0-beta2, 2.9.0-beta3, 2.9.0-beta4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: discourse 2.8.4. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/ae6a9079436fb9b20fd051d25fb6d8027f0ec59a
- https://github.com/discourse/discourse/pull/17071
- https://github.com/discourse/discourse/security/advisories/GHSA-5f4f-35fx-gqhq
- https://github.com/discourse/discourse/commit/ae6a9079436fb9b20fd051d25fb6d8027f0ec59a
- https://github.com/discourse/discourse/pull/17071
- https://github.com/discourse/discourse/security/advisories/GHSA-5f4f-35fx-gqhq
Get alerted when CVE-2022-31060 or the next vulnerability affects your stack