What’s Vulnerable › Vulnerabilities
CVE-2022-31061: SQL injection on login page in GLPI
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 51.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-28 · updated 2026-06-17
- Weakness: CWE-89
Description
GLPI is a Free Asset and IT Management Software package, Data center management, ITIL Service Desk, licenses tracking and software auditing. In affected versions there is a SQL injection vulnerability which is possible on login page. No user credentials are required to exploit this vulnerability. Users are advised to upgrade as soon as possible. There are no known workarounds for this issue.
Affected products
- glpi-project glpi: from 9.3.0 before 9.5.8; from 10.0.0 before 10.0.2 — fixed in 10.0.2, 9.5.8
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.2, 9.5.8. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/21ae07d00d0b3230f6235386e98388cfc5bb0514
- https://github.com/glpi-project/glpi/security/advisories/GHSA-w2gc-v2gm-q7wq
- https://github.com/glpi-project/glpi/commit/21ae07d00d0b3230f6235386e98388cfc5bb0514
- https://github.com/glpi-project/glpi/security/advisories/GHSA-w2gc-v2gm-q7wq
Get alerted when CVE-2022-31061 or the next vulnerability affects your stack