What’s Vulnerable › Vulnerabilities
CVE-2022-31063: Cross site scripting via the title of a document in Tuleap
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Tuleap is a Free & Open Source Suite to improve management of software developments and collaboration. In versions prior to 13.9.99.111 the title of a document is not properly escaped in the search result of MyDocmanSearch widget and in the administration page of the locked documents. A malicious user with the capability to create a document could force victim to execute uncontrolled code. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- Enalean tuleap: before 13.9.99.111; from 13.8.0 before 13.8.6; from 13.9.0 before 13.9.3 — fixed in 13.8.6, 13.9.3, 13.9.99.111
How to fix
Upgrade to a fixed version: Enalean tuleap 13.8.6, 13.9.3, 13.9.99.111. Check the vendor advisory for mitigations.
References
- https://github.com/Enalean/tuleap/commit/c947975a4f1ff7bbfd7d5cd24a2e16bf12bd96d4
- https://github.com/Enalean/tuleap/security/advisories/GHSA-4fx8-4ff3-96jf
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=c947975a4f1ff7bbfd7d5cd24a2e16bf12bd96d4
- https://tuleap.net/plugins/tracker/?aid=27173
- https://github.com/Enalean/tuleap/commit/c947975a4f1ff7bbfd7d5cd24a2e16bf12bd96d4
- https://github.com/Enalean/tuleap/security/advisories/GHSA-4fx8-4ff3-96jf
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=c947975a4f1ff7bbfd7d5cd24a2e16bf12bd96d4
- https://tuleap.net/plugins/tracker/?aid=27173
Get alerted when CVE-2022-31063 or the next vulnerability affects your stack